Cant join Server Anymore / Timed out

Mollo66

Regular
Member
Oct 10, 2020
2
0
1
21
#1
I was messing around on my island with some automation. and i tried to open the fluid infuser inventory. it didnt work suddenly then i tried to open a chest, me system and everything nothing would work but i could still go into normal inventory (E).
Since Nothing worked i left the server. Once i tried to Rejoin the server the message TIMED OUT came. i have tried several times and it still doesnt work.
I usually play on the server B (which is the one with the timed out message) but i could join server A and other skyfactory 4 servers.
I dont know what to do to fix it. but maybe a server restart would fix it.
And could anyone do me a favor and check my island is the fluid infuser machine is still placed? i placed it right behind two simulation chambers that are located near my ME Drive tower. The fluid infuser usually stand ontop of a ME fluid export.
if the machine is there i dont know what the problem is but if the machine isnt there its probably because of me shift clicking The machine with bare hands and lifting it.
I think may be happening because i logged out while lifting the Fluid Infuser (Shift + Left click) (holding it in offhand)
I really like playing on the server and ive come far so i dont want to lose everything now.....